• Now all data be ready for publish, We had made our blog alive now. Haha.



  • These days CCP GFW blocked all the IPs from US and when I switch my IP in google Cloud, the disk data cannot be restore again. I have to restart my blog totally, Now the website is still building…



Q: Create-nuxt-app creates nuxt with 2.0.0 even if it’s 2.8.0 – Stack Overflow

Vue PingBook 3 weeks ago (10-23) 12 0

Question

:
I have an issue with installing nuxt.

The thing is,yarn global list shows

info “create-nuxt-app@2.8.0” has binaries:
– create-nuxt-app

After running yarn create nuxt-app I check my package.json which shows “nuxt”: “^2.0.0”

Why so? I checked that the latest nuxt version is 2.8.1, shouldn’t it be 2.8.1 in package.json?

Answer

:
There are two different packages at play here. First we have create-nuxt-app, which scaffolds your project and is at version 2.8.0.

That scaffold contains the package.json template, which is used to generate the package.json of your project. It contains “nuxt”: “^2.0.0”, where the ^ means: “Get me the latest minor version (and patch version) of nuxt 2”, which as time of writing is 2.8.1. See also What’s the difference between tilde(~) and caret(^) in package.json?

In conclusion, there is no need to update that template file everytime a new nuxt version is released, you’ll always get the latest 2.x.x version of nuxt.




Copyright from PingBook Blog, If not specified, they are original. This site uses BY-NC-SAProtocol authenticated.
For reprinting, please indicate the link of the original text:Q: Create-nuxt-app creates nuxt with 2.0.0 even if it’s 2.8.0 – Stack Overflow
LIKE (0)
[1725641479@qq.com]
SHARE (0)
PingBook
Author:
We create, We sharing! Tag every value data your sharing
Submit comments
Cancel comments
emoji picture bold strikethrough center italic check in

Hi,you need to provide your name and email adress!

  • Name (Required)
  • Email (Required)
  • Website